A fix has been implemented and we are currently monitoring the results.
All emails that were queued during the downtime will automatically be re-sent, so there is nothing you need to do on your side.
Posted May 20, 2026 - 10:53 BST
Identified
The issue has been identified and a fix is being implemented, we are working with our email provider to restore service. Thank you for bearing with us.
Posted May 20, 2026 - 07:29 BST
Investigating
No emails are being sent from Semble. The technical team are currently investigating the issue.