Reduced Performance experienced

Incident Report for Semble Status Page

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 13:04 BST

Identified

The issue has been identified and a fix is being prepared.

Thank you for your continued patience.
Posted Aug 28, 2025 - 12:52 BST

Investigating

We are aware of an issue that could cause difficulties to log in your Semble account or to navigate.

Our engineers are currently investigating the issue.

We are sorry for the inconvenience. Thank you for your patience.
Posted Aug 28, 2025 - 12:26 BST
This incident affected: Semble.