Reduced Performance experienced

Incident Report for Semble Status Page

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:36 GMT

Monitoring

We are monitoring the situation.
Posted Feb 27, 2026 - 11:49 GMT

Update

We are continuing to investigate the issue that causes slowness in certain parts of your Semble account.

Thank you for your continued patience.
Posted Feb 27, 2026 - 11:08 GMT

Investigating

We are currently experiencing an issue with general performance, particularly slowness navigating from one page to another.

Our engineers are investigating the situation.

Thank you for bearing with us.
Posted Feb 27, 2026 - 10:17 GMT
This incident affected: Semble.