Disruptions on Video Consultations patients links and Heidi integration.

Incident Report for Semble Status Page

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 15:48 GMT

Investigating

We are aware of an issue causing disruptions on video consultations links preventing patients and third parties to load the page.

We are investigating the issue with the highest priority.

Thank you for your patience.
Posted Mar 24, 2026 - 13:31 GMT
This incident affected: Semble.