All emails that were queued during the downtime will automatically be re-sent, so there is nothing you need to do on your side.
Posted May 27, 2026 - 08:22 BST
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted May 27, 2026 - 08:16 BST
Identified
The issue has been identified, we are working with our email provider to restore service. We assure you that no emails will be lost, only delayed. Thank you for bearing with us.
Posted May 27, 2026 - 07:58 BST
Investigating
No emails are being sent from Semble. The technical team are currently investigating the issue.